using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\bCollins, (?:Matthew(?: James)?\b|M\.?(?: ?J\.?)?)(?!\S).*";
string substitution = @"Collins, Matthew";
string input = @" Collins, Matthew James
Collins, Matthew
Collins, Matthew J
Collins, M. J.
Collins, M.J.
Collins, M.
Collins, M.J
Collins, M
Collins, M J";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}