const regex = /.*\bCollins, (?:Matthew(?: James)?\b|M\.?(?: ?J\.?)?)(?!\S).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\bCollins, (?:Matthew(?: James)?\\b|M\\.?(?: ?J\\.?)?)(?!\\S).*', 'gm')
const str = ` Collins, Matthew James
Collins, Matthew
Collins, Matthew J
Collins, M. J.
Collins, M.J.
Collins, M.
Collins, M.J
Collins, M
Collins, M J`;
const subst = `Collins, Matthew`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);