import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\) ";
final String string = "rsync -r -t -p -o -g -v --progress --delete -l -H /Users/ken/Library/Application\\ Support/Sublime\\ Text\\ 3/Packages /Users/ken/Google\\ Drive/__config-GD/ST3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}