re = /(\\) /
str = 'rsync -r -t -p -o -g -v --progress --delete -l -H /Users/ken/Library/Application\\ Support/Sublime\\ Text\\ 3/Packages /Users/ken/Google\\ Drive/__config-GD/ST3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end