$re = '/Mission = {.*?} --End Mission/s';
$str = 'local Mission = {
start_done = false
game_over = false
} --End Mission';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);