re = /Mission = {.*?} --End Mission/
str = 'local Mission = {
start_done = false
game_over = false
} --End Mission'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end