using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([""'])(?:[^\2\n]|\\\2)*\2)";
string input = @"a='';
b='
';
c="";
d=""'"";
e='""';
f='\'';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}