re = /((["'])(?:[^\2\n]|\\\2)*\2)/
str = 'a=\'\';
b=\'
\';
c="";
d="\'";
e=\'"\';
f=\'\\\'\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end