package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:_&_|[^&\n])+`)
var str = `foo_&_bar&baz
foo_&_b_ar&baz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}