$re = '/(?:_&_|[^&\n])+/m';
$str = 'foo_&_bar&baz
foo_&_b_ar&baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);