use strict;
my $str = 'V e r y calm\', \'Keen and a n a l y t i c a l\',
\'R a s h and careless\', \'Always joyful\', \'你 好\', \'黑 石 公 司\'';
my $regex = qr/(?<![a-zA-Z]{2})(?<=[a-zA-Z]{1})[ ]+(?=[a-zA-Z] |.$)|(?<=\p{Han}) +/mup;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";