re = /(?<![a-zA-Z]{2})(?<=[a-zA-Z]{1})[ ]+(?=[a-zA-Z] |.$)|(?<=\p{Han}) +/m
str = 'V e r y calm\', \'Keen and a n a l y t i c a l\',
\'R a s h and careless\', \'Always joyful\', \'你 好\', \'黑 石 公 司\''
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result