package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\P{L}+`)
var str = `1104 Notes receivable
1104 受取手形`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}