$re = '/^\P{L}+/m';
$str = '1104 Notes receivable
1104 受取手形';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);