package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m){{(?P<groupName>[^{}]*)}}`)
var str = `Hello, I'm {{name}} from {{City}}, {{from_state}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}