re = /{{(?P<groupName>[^{}]*)}}/m
str = 'Hello, I\'m {{name}} from {{City}}, {{from_state}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end