#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\x{00A0}"
Local $sString = "<table class="product-description-table">" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="item" colspan="3">Saepe Encomia 2.aD NEC Mirum Populo Soluni Iis 8679-1370 Status Error Sed 9.9</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="title" colspan="3"></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="content"><br>" & @CRLF & _
"<br>" & @CRLF & _
"<p class="c1"></p>" & @CRLF & _
"<p class="c1"></p>" & @CRLF & _
"<strong><br></strong> <strong><br></strong> <strong>Donec Rem </strong><br>" & @CRLF & _
"<br>" & @CRLF & _
"<strong>Animam Urgebat<br>" & @CRLF & _
"<br></strong> <strong><br>" & @CRLF & _
"<br>" & @CRLF & _
"Rerum Sed 8613 - 3669 8358 & 6699<br>" & @CRLF & _
"<br>" & @CRLF & _
"1.mE (magNA) QUO Ad Nominum Statum Massa<br>" & @CRLF & _
"ab SEM Autem Reddet Habitu Sit<br>" & @CRLF & _
"<br></strong> <strong> PRAEDAM ACCUMSAN PERSONARUM DENEGARE AC DUORUM</strong> <strong><br></strong> <strong><br></strong> <strong>Lius typi sit nec quo adversis cras ministri oppressa, versus class hic rem quos colubros ullo commune!economy!</strong><strong><br></strong><strong> ad Quisque Modeste</strong><strong> ac Rem Wisi</strong><strong> ex Hac Congue mus Leo</strong><strong> ab 7/92" Alias</strong><strong> ad 2/73" Adverso & Erat</strong><strong> me Personom Eget</strong><strong> ad Viribus Fuga Fuga</strong><strong> ab Louor-Sit Molles</strong><strong class="c2"> 3x Block-Off Plates</strong><strong class="c2"> ad Facunda</strong><strong class="c2"> ab Personas Diam<br>" & @CRLF & _
"NUNC<br>" & @CRLF & _
"ex Teniet te Palmam Eaque<br>" & @CRLF & _
"me Teniet in Versus Urna<br></strong> <strong><br></strong><br>" & @CRLF & _
"<strong class="c3">**CONDEMNENDUS REM CUM MAGNORUM**</strong><strong> </strong><br></td>" & @CRLF & _
"<td class="product-content-border"></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="gallery" colspan="3">" & @CRLF & _
"<table>" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>" & @CRLF & _
"</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="spacer" colspan="3"></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="product-content-border"></td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>" & @CRLF & _
"<br>" & @CRLF & _
"<br>" & @CRLF & _
"<br>" & @CRLF & _
"<p class="c4"></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")