# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("[a-zA-Z 0-9]+)(?:-\d)+(?=")/\1/gm;t' <<< "\"Article number\" \"Name\" \"Third Column\"
\"Shorts Artic\" \"Swa...\" \"2018-07-28\"
\"Shorts Artic-1\" \"Swa...\" \"stl 31-35-1-1-1-1-2-2-2-1-1\"
\"Shorts Artic-2-1\" \"Swa...\" \"https://test-domain.com/...\"
\"Shorts Artic-2-2-1\" \"Sw...\" \"\"
\"Shorts Artic-2-2-2-2-1\" \"Ba...\" \"-asd\"
\"Shorts Artic-2-2-2-2-2-1\" \"Nus...\"
\"Shorts Artic-2-2-2-2-2-1-1\" \"Lek..\"
\"0858-1\" \"Jacket Blue..\"
\"0858-2-1\" \"Jacket Re..\"
\"0858-2-2-1\" \"Int...\"
\"0858-2-2-2-1\" \"In...\"
\"0858-2-2-2-2-1\" \"Int...\"
\"0858-2-2-2-2-2-1\" \"Int...\"
\"0858-2-2-2-2-2-2-1\" \"Int...\"
\"0858-2-2-2-2-2-2-2-1\" \"In...\"
\"0858-2-2-2-2-2-2-2-2\" \"In...\"
\"0858-2-2-2-2-2-2-2-1\" \"In...\" \"6 107-124 cm\""