#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^"((?:[a-zA-z]+ ?)+|[0-9]+)(?:-?\d)+(?=")"
Local $sString = ""Article number" "Name" "Third Column"" & @CRLF & _
""Shorts Artic" "Swa..." "2018-07-28"" & @CRLF & _
""Shorts Artic-1" "Swa..." """ & @CRLF & _
""Shorts Artic-2-1" "Swa..." "https://test-domain.com/..."" & @CRLF & _
""Shorts Artic-2-2-1" "Sw..." """ & @CRLF & _
""Shorts Artic-2-2-2-2-1" "Ba..." "-asd"" & @CRLF & _
""Shorts Artic-2-2-2-2-2-1" "Nus..."" & @CRLF & _
""Shorts Artic-2-2-2-2-2-1-1" "Lek.."" & @CRLF & _
""0858-1" "Jacket Blue.."" & @CRLF & _
""0858-2-1" "Jacket Re.."" & @CRLF & _
""0858-2-2-1" "Int..."" & @CRLF & _
""0858-2-2-2-1" "In..."" & @CRLF & _
""0858-2-2-2-2-1" "Int..."" & @CRLF & _
""0858-2-2-2-2-2-1" "Int..."" & @CRLF & _
""0858-2-2-2-2-2-2-1" "Int..."" & @CRLF & _
""0858-2-2-2-2-2-2-2-1" "In..."" & @CRLF & _
""0858-2-2-2-2-2-2-2-2" "In..."" & @CRLF & _
""0858-2-2-2-2-2-2-2-1" "In..." "6 107-124 cm"" & @CRLF & _
""stl 31-35-1-1-1-1-2-2-2-1-1" "In...""
Local $sSubst = ""\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)