import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"((?:[a-zA-z]+ ?)+|[0-9]+)(?:-?\\d)+(?=\")";
final String string = "\"Article number\" \"Name\" \"Third Column\"\n"
+ "\"Shorts Artic\" \"Swa...\" \"2018-07-28\"\n"
+ "\"Shorts Artic-1\" \"Swa...\" \"\"\n"
+ "\"Shorts Artic-2-1\" \"Swa...\" \"https://test-domain.com/...\"\n"
+ "\"Shorts Artic-2-2-1\" \"Sw...\" \"\"\n"
+ "\"Shorts Artic-2-2-2-2-1\" \"Ba...\" \"-asd\"\n"
+ "\"Shorts Artic-2-2-2-2-2-1\" \"Nus...\"\n"
+ "\"Shorts Artic-2-2-2-2-2-1-1\" \"Lek..\"\n"
+ "\"0858-1\" \"Jacket Blue..\"\n"
+ "\"0858-2-1\" \"Jacket Re..\"\n"
+ "\"0858-2-2-1\" \"Int...\"\n"
+ "\"0858-2-2-2-1\" \"In...\"\n"
+ "\"0858-2-2-2-2-1\" \"Int...\"\n"
+ "\"0858-2-2-2-2-2-1\" \"Int...\"\n"
+ "\"0858-2-2-2-2-2-2-1\" \"Int...\"\n"
+ "\"0858-2-2-2-2-2-2-2-1\" \"In...\"\n"
+ "\"0858-2-2-2-2-2-2-2-2\" \"In...\"\n"
+ "\"0858-2-2-2-2-2-2-2-1\" \"In...\" \"6 107-124 cm\"\n"
+ "\"stl 31-35-1-1-1-1-2-2-2-1-1\" \"In...\"";
final String subst = "\"\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}