const regex = /(.+?)[ ]?((?<=[ ])\(cost=([\d\.]+)[ ]rows=(\d+)\))?[ ]\(actual[ ]time=([\d\.]+)[ ]rows=(\d+)[ ]loops=(\d+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)[ ]?((?<=[ ])\\(cost=([\\d\\.]+)[ ]rows=(\\d+)\\))?[ ]\\(actual[ ]time=([\\d\\.]+)[ ]rows=(\\d+)[ ]loops=(\\d+)\\)', 'gm')
const str = `Single-row index lookup on using <auto_distinct_key> (actor_id=actor.actor_id) (cost=901.66 rows=5478) (actual time=0.001..0.001 rows=0 loops=200)
Single-row index lookup on using <auto_distinct_key> (actor_id=actor.actor_id) (actual time=0.001..0.001 rows=0 loops=200)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}