re = /(.+?)[ ]?((?<=[ ])\(cost=([\d\.]+)[ ]rows=(\d+)\))?[ ]\(actual[ ]time=([\d\.]+)[ ]rows=(\d+)[ ]loops=(\d+)\)/m
str = 'Single-row index lookup on using <auto_distinct_key> (actor_id=actor.actor_id) (cost=901.66 rows=5478) (actual time=0.001..0.001 rows=0 loops=200)
Single-row index lookup on using <auto_distinct_key> (actor_id=actor.actor_id) (actual time=0.001..0.001 rows=0 loops=200)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end