#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:\u23F1.\W|[\d]+)(\'|\s|’|‘)*(/|\||\[|-)+)|((/|\||\[)+(\s)*(?:\u23F1)*(\s)*[\d]{1,2}[^x](\s)*(min|mi|m)*)"
Local $sString = "((?:\u23F1.\W|[\d]+)(\'|\s|’|‘)*(/|\||\[|-)+)|((/|\||\[)+(\s)*(?:\u23F1)*(\s)*[\d]{1,2}[^x](\s)*(min|mi|m)*)" & @CRLF & _
"" & @CRLF & _
"2ºT | ⏱ 48 min: cruzamento de Raphael Veiga e Felipe Melo cabeceia para fora. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão" & @CRLF & _
"2ºT | ⏱ 47 min: amarelo para Raphael Veiga. \n\n#PALxCHA | 3x1\n#AvantiPalestra " & @CRLF & _
"2ºT | ⏱ 45 min: mais 4 minutos de acréscimos. \n\n#PALxCHA | 3x1\n#AvantiPalestra " & @CRLF & _
"2ºT | ⏱ 42 min: cruzamento preciso de Luan do meio-campo e Rony cabeceia para fora. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão" & @CRLF & _
"2ºT | ⏱ 28 min: substituições 🔄\n\n🔼 Entram: L. Esteves e F. Melo \n🔽 Saem: Wesley e G. Scarpa " & @CRLF & _
"2ºT | ⏱ 26 min: amarelo para Wesley. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão" & @CRLF & _
"Com a saída de Luiz Adriano, Willian passa a ser o capitão do time em campo ©️\n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão https://t.co/PbpAHZH68u" & @CRLF & _
"2ºT | ⏱ 25 min: substituição 🔄\n\n🔼 Entra: Willian \n🔽 Sai: Luiz Adriano \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão" & @CRLF & _
"2ºT | ⏱ 21 min: após bate e rebate, Zé Rafael fica com a bola e manda por cima do gol. \n\n#PALxCHA | 3x1\n#AvantiPalestra \n#JuntosNoBrasileirão" & @CRLF & _
"2ºT | ⏱ 9 min: Palmeiras 3x1 Chapecoense. \n\n#AvantiPalestra #PALxCHA\n#JuntosNoBrasileirão" & @CRLF & _
"2ºT | ⏱ 3 min: jogada ensaiada em cobrança de escanteio: Gustavo Scarpa cruza na entrada da área para 45' | 2T | +6. Jogo vai aos 51. \n\nABC Futebol Clube 3x0 Chapecoense\n \n#VamosChape " & @CRLF & _
"43' | 2T | Entra Felipe Santana no lugar de Matheus Ribeiro. \n\nABC Futebol Clube 3x0 Chapecoense\n " & @CRLF & _
"45' | 2T | +4. Jogo vai aos 49. \n\nPalmeiras 3x1 Chapecoense\n \n#VamosChape #OrgulhoDeSerChape" & @CRLF & _
"35' | 2T | Muda a Chape:\n\nEntram ➡️ Bruno Silva e Geuvânio\nSaem ⬅️Fabinho e Anselmo Ramon " & @CRLF & _
"32' | 2T | Adversário cobra falta, mas a bola desvia na barreira e sai em escanteio. \n\nPalmeiras 3x1" & @CRLF & _
"24' | 2T | QUAAAAAAAASEEEEEEEEEE! \n\nRavanelli manda no segundo pau e Anselmo Ramon finaliza de " & @CRLF & _
"13' | 2T | Ravanelli tocou para Matheus Ribeiro, que invadiu a área a finalizou na rede, mas pelo lado" & @CRLF & _
"7' | 2T | Falta para a Chapecoense na meia-lua da grande área. \n\nPalmeiras 3x0 Chapecoense\n " & @CRLF & _
"7' | 1T | Gol do Palmeiras. \n\nPalmeiras 1x0 Chapecoense\n \n#VamosChape #OrgulhoDeSerChape" & @CRLF & _
"2' | 1T | UHHHHHHHHHHHHHHHHHHH!\n\nFabinho fica cara a cara com Jailson e finaliza, obrigando grande " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")