const regex = /(?<=IT[\s\S]+)([A-Z][a-z]+[\d\s\,]+)(?=\s[\s\S]+requirement)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=IT[\\s\\S]+)([A-Z][a-z]+[\\d\\s\\,]+)(?=\\s[\\s\\S]+requirement)', 'gm')
const str = `I am an IT professional working in Southern India.
I joined my new organization on April 20, 2024
My requirement happened through campus hire program.
I will be working on UiPath and Dot net related projects.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}