$re = '/(?<=IT[\s\S]+)([A-Z][a-z]+[\d\s\,]+)(?=\s[\s\S]+requirement)/m';
$str = 'I am an IT professional working in Southern India.
I joined my new organization on April 20, 2024
My requirement happened through campus hire program.
I will be working on UiPath and Dot net related projects.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);