package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[1-9][0-9]+`)
var str = `D00001526
F000018545`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}