$re = '/[1-9][0-9]+/m';
$str = 'D00001526
F000018545';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);