using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""name""\s*:\s*""[^""]*password[^""]*"",\s*""value""\s*:\s*""([^""]*)";
string input = @"""apps"":[
""settings"": [
{
""name"" : ""sometext-v1.password-v1"",
""value"" : ""myPassword""
},
...
...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}