re = /"name"\s*:\s*"[^"]*password[^"]*",\s*"value"\s*:\s*"([^"]*)/m
str = '"apps":[
"settings": [
{
"name" : "sometext-v1.password-v1",
"value" : "myPassword"
},
...
...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end