package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`CREATE +?(TEMPORARY +)?TABLE *(?P<db>.*?\.)?(?P<table>.*?)\((?P<col>.*?)\).*?USING.*?(PARTITIONED BY \((?P<pcol>.*?)\))`)
var str = `CREATE TEMPORARY TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet PARTITIONED BY (DATA2, DATA3)
CREATE TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}