use strict;
my $str = 'CREATE TEMPORARY TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet PARTITIONED BY (DATA2, DATA3)
CREATE TABLE db.table (DATA2 int, DATA3 int, DATA4 int) USING parquet';
my $regex = qr/CREATE +?(TEMPORARY +)?TABLE *(?P<db>.*?\.)?(?P<table>.*?)\((?P<col>.*?)\).*?USING.*?(PARTITIONED BY \((?P<pcol>.*?)\))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}