$re = '/^(?!tom tom[^A-Za-z\'$])([A-Za-z\'$]+ [A-Za-z\'$]+) went to college/m';
$str = 'tom tom went to college
\'tom tom went to college
to\'m tom went to college
tom to\'m went to college
tom tom\' went to college
tom tom\'s went to college
tom tom$ went to college
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);