re = /^(?!tom tom[^A-Za-z'$])([A-Za-z'$]+ [A-Za-z'$]+) went to college/m
str = 'tom tom went to college
\'tom tom went to college
to\'m tom went to college
tom to\'m went to college
tom tom\' went to college
tom tom\'s went to college
tom tom$ went to college
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end