$re = '/^(?:(?:(?:(?:(?:[13579][26]|[2468][048])00)|(?:[0-9]{2}(?:(?:[13579][26])|(?:[2468][048]|0[48]))))(?:(?:(?:09|04|06|11)(?:0[1-9]|1[0-9]|2[0-9]|30))|(?:(?:01|03|05|07|08|10|12)(?:0[1-9]|1[0-9]|2[0-9]|3[01]))|(?:02(?:0[1-9]|1[0-9]|2[0-9]))))|(?:[0-9]{4}(?:(?:(?:09|04|06|11)(?:0[1-9]|1[0-9]|2[0-9]|30))|(?:(?:01|03|05|07|08|10|12)(?:0[1-9]|1[0-9]|2[0-9]|3[01]))|(?:02(?:[01][0-9]|2[0-8])))))(([_]{1})[a-zA-Z-zÀ-ÿ-0-9\s]+?(?=_)([_]{1})(([0-9]+?(?=[.]))|([0-9]+?(?=[_])([_]{1})[a-zA-Z-zÀ-ÿ-0-9\s]+?(?=[.]))|([a-zA-Z-zÀ-ÿ-0-9\s]+?(?=_)([_]{1})(([0-9]+?(?=[.]))|([0-9]+?(?=_)([_]{1})[a-zA-Z-zÀ-ÿ-0-9\s]+?(?=[.]))))))/m';
$str = '
20220103
20220103_type_67676.txt
20220103_ty ççpe_67676.txt
20220103_typ çw3434ç sdf ççe_67676.txt
20220103_type_sousType_67676.txt
20220103_type_sousType_67676_test.txt
20220103_tyéàààçççççééééêê432èèèè èïÜüïîÛÜÄçpe_67676.txt
20220103_tééééêê432èèype_sééééêê432èèsousType_67676.txt
20220103_tééééêê432èèype_sééééêê432èèsousType_67676_libre.txt
20211231_CA_80001_champ libre.txt
20220103_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);