# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:(?:(?:[13579][26]|[2468][048])00)|(?:[0-9]{2}(?:(?:[13579][26])|(?:[2468][048]|0[48]))))(?:(?:(?:09|04|06|11)(?:0[1-9]|1[0-9]|2[0-9]|30))|(?:(?:01|03|05|07|08|10|12)(?:0[1-9]|1[0-9]|2[0-9]|3[01]))|(?:02(?:0[1-9]|1[0-9]|2[0-9]))))|(?:[0-9]{4}(?:(?:(?:09|04|06|11)(?:0[1-9]|1[0-9]|2[0-9]|30))|(?:(?:01|03|05|07|08|10|12)(?:0[1-9]|1[0-9]|2[0-9]|3[01]))|(?:02(?:[01][0-9]|2[0-8])))))(([_]{1})[a-zA-Z-zÀ-ÿ-0-9\s]+?(?=_)([_]{1})(([0-9]+?(?=[.]))|([0-9]+?(?=[_])([_]{1})[a-zA-Z-zÀ-ÿ-0-9\s]+?(?=[.]))|([a-zA-Z-zÀ-ÿ-0-9\s]+?(?=_)([_]{1})(([0-9]+?(?=[.]))|([0-9]+?(?=_)([_]{1})[a-zA-Z-zÀ-ÿ-0-9\s]+?(?=[.]))))))"
test_str = ("\n"
"20220103\n"
"20220103_type_67676.txt\n"
"20220103_ty ççpe_67676.txt\n"
"20220103_typ çw3434ç sdf ççe_67676.txt\n"
"20220103_type_sousType_67676.txt\n"
"20220103_type_sousType_67676_test.txt\n"
"20220103_tyéàààçççççééééêê432èèèè èïÜüïîÛÜÄçpe_67676.txt\n"
"20220103_tééééêê432èèype_sééééêê432èèsousType_67676.txt\n"
"20220103_tééééêê432èèype_sééééêê432èèsousType_67676_libre.txt\n"
"20211231_CA_80001_champ libre.txt\n"
"20220103_")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.