$re = '/^(?=.*?(father)).*?(mother)/m';
$str = 'my father and mother
my mother and father';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);