re = /^(?=.*?(father)).*?(mother)/m
str = 'my father and mother
my mother and father'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end