$re = '/^(?![@=*-])(?!.*[<>]).*$/m';
$str = '123abc
Hello > World
Other < bracket
=hello
*world
-stuff
@other
%valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);