re = /^(?![@=*-])(?!.*[<>]).*$/m
str = '123abc
Hello > World
Other < bracket
=hello
*world
-stuff
@other
%valid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end