package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<Field1>[^ ]*)\s-\s(?<Field2>[^ ]*)\s-\s(?<Field3>.*)`)
var str = `KM - PROD - MSSQL 2008 VA
DC - PROD - MSSQL 2012 VA
KM - WDC - MSSQL VA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}