$re = '/^(?<Field1>[^ ]*)\s-\s(?<Field2>[^ ]*)\s-\s(?<Field3>.*)/';
$str = 'KM - PROD - MSSQL 2008 VA
DC - PROD - MSSQL 2012 VA
KM - WDC - MSSQL VA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);