import Foundation
let pattern = #"\bint\s+(?:(?:[A-Z](?:[a-z](?![a-z])|[0-9](?![0-9])|_(?!__))+)(?:,\s*|\s*;)){1,5}(?<=;)|\b(?:bool|double)\s+(?:(?:[A-Z](?:[a-z0-9]+|_(?!__))+)(?:,\s*|\s*;)){1,5}(?<=;)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Valid:
int Xy;
double A1b, B_2;
bool Cx, D3_z;
Invalid:
int X;
int X___y;
int XY;
int X11;
double 1A;
int Xy, A1b, B_2, C3_d, D4e, E5f;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)