import re
regex = re.compile(r".*def[\s\\]*?(\w+)[\s\\]*?\(([\w\W]*?)\)(?:[\s\\]*?->[\s\\]*?([\w\(\)\[\]\,]+))?[\s\\]*?:", flags=re.MULTILINE)
test_str = ("def foo():\n"
"def foo()->None:\n"
"def foo()->None :\n"
"def foo()-> None :\n"
"def foo()-> tuple[None,None] :\n"
"def foo()->tuple[None,None]:\n"
"def foo()->tuple[None,None] :\n"
"def foo()-> tuple[None,None]:\n"
"def foo()-> (None,) :\n"
"def foo()->(None,) :\n"
"def foo()-> (None,):\n"
"def foo()->(None,):\n"
"def _foo():\n"
"def _123foo():\n"
"def _123foo__():\n"
"def _123foo__24():\n"
"def foo(x):\n"
"def foo(x,y):\n"
"def foo(x:int):\n"
"def foo(x:int,y:float):\n"
"def foo(x:int,y:float)->None:\n"
"def foo(x:int,y:float) ->None:\n"
"def foo(x:int,y:float) -> None:\n"
"def \\\n"
" foo\\\n"
" (x:int,y:float)->None\n"
" :\n"
"def foo(func : Callable[[int,int],\\\n"
" int]):")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")