import Foundation
let pattern = #".*def[\s\\]*?(\w+)[\s\\]*?\(([\w\W]*?)\)(?:[\s\\]*?->[\s\\]*?([\w\(\)\[\]\,]+))?[\s\\]*?:"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
def foo():
def foo()->None:
def foo()->None :
def foo()-> None :
def foo()-> tuple[None,None] :
def foo()->tuple[None,None]:
def foo()->tuple[None,None] :
def foo()-> tuple[None,None]:
def foo()-> (None,) :
def foo()->(None,) :
def foo()-> (None,):
def foo()->(None,):
def _foo():
def _123foo():
def _123foo__():
def _123foo__24():
def foo(x):
def foo(x,y):
def foo(x:int):
def foo(x:int,y:float):
def foo(x:int,y:float)->None:
def foo(x:int,y:float) ->None:
def foo(x:int,y:float) -> None:
def \
foo\
(x:int,y:float)->None
:
def foo(func : Callable[[int,int],\
int]):
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)