package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w*_(?P<text>\w+)`)
var str = `text_BlaBla
123_Text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}