$re = '/^\w*_(?P<text>\w+)/m';
$str = 'text_BlaBla
123_Text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);