#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?|^(?=(\".*?\"|[^\r\n\"]+)@)(?!.*?@(\..*?\.|\..*?|.*?\.|.{256,})$)(?=(.*?@([a-z0-9\-]{1,63}\.)+|^)[a-z0-9\-\.]{1,64}$)((?!\.|^.*?\.{2,}.*?@)[a-z0-9_\-\.\"!#$%&'*+ \/=?^`{|}~]{1,64}@(?<!\.@)(?!\-|.*?(\.\.|@).*?)([^\.]{1,63}|([a-z0-9\-\.]{1,63})+)(?<!\-)\.[a-z\d\-]{2,24})$)"
Local $sString = "Valid email addresses" & @CRLF & _
"" & @CRLF & _
""acc"@bcc.ccc" & @CRLF & _
"simple@example.com" & @CRLF & _
"very.common@example.com" & @CRLF & _
"disposable.style.email.with+symbol@example.com" & @CRLF & _
"other.email-with-hyphen@example.com" & @CRLF & _
"fully-qualified-domain@example.com" & @CRLF & _
"user.name+tag+sorting@example.com" & @CRLF & _
"x@example.com" & @CRLF & _
"example-indeed@strange-example.com" & @CRLF & _
"" "@example.org" & @CRLF & _
"#!$%&'*+-/=?^_`{}|~@example.org" & @CRLF & _
"example@s.example" & @CRLF & _
"" & @CRLF & _
"[ === WILL NEED TO CHECK THESE === ]" & @CRLF & _
""()<>[]:,;@\\\"!#$%&'-/=?^_`{}| ~.a"@example.org" & @CRLF & _
""very.(),:;<>[]\".VERY.\"very@\\ \"very\".unusual"@strange.example.com" & @CRLF & _
"user@[2001:DB8::1]" & @CRLF & _
"admin@mailserver1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Invalid email addresses:" & @CRLF & _
"" & @CRLF & _
"Abc.example.com" & @CRLF & _
"A@b@c@example.com" & @CRLF & _
"a"b(c)d,e:f;g<h>i[j\k]l@example.com" & @CRLF & _
"just"not"right@example.com" & @CRLF & _
"this is"not\allowed@example.com" & @CRLF & _
"this\ still\"not\\allowed@example.com" & @CRLF & _
"1234567890123456789012345678901234567890123456789012345678901234+x@example.com" & @CRLF & _
"john..doe@example.com" & @CRLF & _
"john.doe@example..com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")