const regex = /(?|^(?=(\".*?\"|[^\r\n\"]+)@)(?!.*?@(\..*?\.|\..*?|.*?\.|.{256,})$)(?=(.*?@([a-z0-9\-]{1,63}\.)+|^)[a-z0-9\-\.]{1,64}$)((?!\.|^.*?\.{2,}.*?@)[a-z0-9_\-\.\"!#$%&'*+ \/=?^`{|}~]{1,64}@(?<!\.@)(?!\-|.*?(\.\.|@).*?)([^\.]{1,63}|([a-z0-9\-\.]{1,63})+)(?<!\-)\.[a-z\d\-]{2,24})$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|^(?=(\\".*?\\"|[^\\r\\n\\"]+)@)(?!.*?@(\\..*?\\.|\\..*?|.*?\\.|.{256,})$)(?=(.*?@([a-z0-9\\-]{1,63}\\.)+|^)[a-z0-9\\-\\.]{1,64}$)((?!\\.|^.*?\\.{2,}.*?@)[a-z0-9_\\-\\.\\"!#$%&\'*+ \\\/=?^`{|}~]{1,64}@(?<!\\.@)(?!\\-|.*?(\\.\\.|@).*?)([^\\.]{1,63}|([a-z0-9\\-\\.]{1,63})+)(?<!\\-)\\.[a-z\\d\\-]{2,24})$)', 'gim')
const str = `Valid email addresses
"acc"@bcc.ccc
simple@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
x@example.com
example-indeed@strange-example.com
" "@example.org
#!\$%&'*+-/=?^_\`{}|~@example.org
example@s.example
[ === WILL NEED TO CHECK THESE === ]
"()<>[]:,;@\\\\\\"!#\$%&'-/=?^_\`{}| ~.a"@example.org
"very.(),:;<>[]\\".VERY.\\"very@\\\\ \\"very\\".unusual"@strange.example.com
user@[2001:DB8::1]
admin@mailserver1
Invalid email addresses:
Abc.example.com
A@b@c@example.com
a"b(c)d,e:f;g<h>i[j\\k]l@example.com
just"not"right@example.com
this is"not\\allowed@example.com
this\\ still\\"not\\\\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
john..doe@example.com
john.doe@example..com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}