using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bapple\b(.*?)\beach\b(?! box)";
string input = @"1)`apple costs 5 dollars each` -> `costs 5 dollars`
2)`apple costs 5 dollars each box` -> ``";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}