re = /\bapple\b(.*?)\beach\b(?! box)/m
str = '1)`apple costs 5 dollars each` -> `costs 5 dollars`
2)`apple costs 5 dollars each box` -> ``'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end